Postico App Icon Postico 2

Old versions of Postico

Postico 2

The current version of Postico 2 requires macOS 10.15 (Catalina)

If you have macOS 10.13 or later, you can download Postico 2.0 RC 5.

Postico 1.5

The latest version of Postico 1.5 runs on macOS 10.10 or later. Download it from the Postico 1.5 Website.

If you are still on macOS 10.9, you can download Postico 1.2.4.

For Macs running macOS 10.8 you can download Postico 0.26.

PG Commander

The predecessor of Postico, PG Commander, no longer works well on modern versions of macOS and PostgreSQL. Using it is no longer recommended. If you really want to, you can download PG Commander 1.5.9 (requires macOS 10.8 or later)